Re: [PATCH 01/13] kernel/irq/proc: use seq_put_decimal_ull_width() for decimal values

From: David Wang
Date: Tue Nov 19 2024 - 23:24:41 EST



At 2024-11-20 09:20:59, "Thomas Gleixner" <tglx@xxxxxxxxxxxxx> wrote:
>On Tue, Nov 19 2024 at 20:55, Geert Uytterhoeven wrote:
>> E.g. on Koelsch (R-Car M-W), the output changes from:
>>
>> CPU0 CPU1
>> 27: 1871 2017 GIC-0 27 Level arch_timer
>> 29: 646 0 GIC-0 205 Level e60b0000.i2c
>> 30: 0 0 GIC-0 174 Level ffca0000.timer
>> 31: 0 0 GIC-0 36 Level e6050000.gpio
>> 32: 0 0 GIC-0 37 Level e6051000.gpio
>> [...]
>>
>> to
>>
>> CPU0 CPU1
>> 27: 1966 1900GIC-0 27 Level arch_timer
>> 29: 580 0GIC-0 205 Level e60b0000.i2c
>> 30: 0 0GIC-0 174 Level ffca0000.timer
>> 31: 0 0GIC-0 36 Level e6050000.gpio
>> 32: 0 0GIC-0 37 Level e6051000.gpio
>> [...]
>>
>> making the output hard to read, and probably breaking scripts that parse
>> its contents.
>>
>> Reverting the commit fixes the issue for me.
>
>Interestingly enough the generic version and quite some of the chip
>specific print functions have a leading space, but GIC does not.
>
>The below should restore the original state.
>
>Thanks,
>
> tglx
>---
>diff --git a/kernel/irq/proc.c b/kernel/irq/proc.c
>index f36c33bd2da4..9b715ce8cf2e 100644
>--- a/kernel/irq/proc.c
>+++ b/kernel/irq/proc.c
>@@ -501,6 +501,7 @@ int show_interrupts(struct seq_file *p, void *v)
>
> seq_put_decimal_ull_width(p, " ", cnt, 10);
> }
>+ seq_putc(p, ' ');
>
> raw_spin_lock_irqsave(&desc->lock, flags);
> if (desc->irq_data.chip) {

On second thought, considering other paths have already had a leading space,
maybe it is more clean to just add a leading space before irq_print_chip:

raw_spin_lock_irqsave(&desc->lock, flags);
if (desc->irq_data.chip) {
- if (desc->irq_data.chip->irq_print_chip)
+ if (desc->irq_data.chip->irq_print_chip) {
+ seq_putc(p, ' ');
desc->irq_data.chip->irq_print_chip(&desc->irq_data, p);
- else if (desc->irq_data.chip->name)
+ } else if (desc->irq_data.chip->name)
seq_printf(p, " %8s", desc->irq_data.chip->name);
else
seq_printf(p, " %8s", "-");



David