[GIT PULL] Driver core changes for 6.13-rc1

From: Greg KH
Date: Thu Nov 28 2024 - 23:36:34 EST


The following changes since commit 59b723cd2adbac2a34fc8e12c74ae26ae45bf230:

Linux 6.12-rc6 (2024-11-03 14:05:52 -1000)

are available in the Git repository at:

git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git tags/driver-core-6.13-rc1

for you to fetch changes up to acfeb6defcb9310b1ff44db1e633798ba766337d:

Fix a potential abuse of seq_printf() format string in drivers (2024-11-22 15:31:35 +0100)

----------------------------------------------------------------
Driver core changes for 6.13-rc1

Here is a small set of driver core changes for 6.13-rc1.

Nothing major for this merge cycle, except for the 2 simple merge
conflicts are here just to make life interesting.

Included in here are:
- sysfs core changes and preparations for more sysfs api cleanups that
can come through all driver trees after -rc1 is out
- fw_devlink fixes based on many reports and debugging sessions
- list_for_each_reverse() removal, no one was using it!
- last-minute seq_printf() format string bug found and fixed in many
drivers all at once.
- minor bugfixes and changes full details in the shortlog

As mentioned above, there is 2 merge conflicts with your tree, one is
where the file is removed (easy enough to resolve), the second is a
build time error, that has been found in linux-next and the fix can be
seen here:
https://lore.kernel.org/r/20241107212645.41252436@xxxxxxxxxxxxxxxx

Other than that, the changes here have been in linux-next with no other
reported issues.

Signed-off-by: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx>

----------------------------------------------------------------
Amit Vadhavana (1):
drivers: core: fw_devlink: Fix excess parameter description in docstring

Bartosz Golaszewski (1):
driver core: constify devlink class

David Wang (1):
Fix a potential abuse of seq_printf() format string in drivers

Dr. David Alan Gilbert (1):
drivers/base: Remove unused auxiliary_find_device

Gaosheng Cui (1):
firmware_loader: Fix possible resource leak in fw_log_firmware_info()

Geert Uytterhoeven (1):
driver core: auxiliary bus: Spelling s/pecific/specific/

Greg Kroah-Hartman (1):
Merge 6.12-rc6 into driver-core-next

Julia Lawall (1):
firmware_loader: Reorganize kerneldoc parameter names

Keita Morisaki (1):
devres: Fix page faults when tracing devres from unloaded modules

Nathan Chancellor (1):
cdx: Fix cdx_mmap_resource() after constifying attr in ->mmap()

Nikolay Borisov (1):
cacheinfo: Don't opencode per_cpu_cacheinfo()

Rob Herring (Arm) (1):
cacheinfo: Use of_property_present() for non-boolean properties

Saravana Kannan (4):
driver core: fw_devlink: Stop trying to optimize cycle detection logic
drm: display: Set fwnode for aux bus devices
phy: tegra: xusb: Set fwnode for xusb port devices
drivers: core: fw_devlink: Make the error message a bit more useful

Thomas Weißschuh (15):
sysfs: explicitly pass size to sysfs_add_bin_file_mode_ns()
sysfs: introduce callback attribute_group::bin_size
PCI/sysfs: Calculate bin_attribute size through bin_size()
nvmem: core: calculate bin_attribute size through bin_size()
sysfs: treewide: constify attribute callback of bin_is_visible()
sysfs: treewide: constify attribute callback of bin_attribute::mmap()
sysfs: treewide: constify attribute callback of bin_attribute::llseek()
sysfs: implement all BIN_ATTR_* macros in terms of __BIN_ATTR()
sysfs: bin_attribute: add const read/write callback variants
driver core: Constify attribute arguments of binary attributes
sysfs: attribute_group: allow registration of const bin_attribute
driver core: Constify bin_attribute definitions
perf: arm-ni: Remove spurious NULL in attribute_group definition
s390/con3215: Remove spurious NULL in attribute_group definition
cpu: Remove spurious NULL in attribute_group definition

Zijun Hu (5):
list: Remove duplicated and unused macro list_for_each_reverse
lib: devres: Simplify API devm_iounmap() implementation
lib: devres: Simplify API devm_ioport_unmap() implementation
driver core: Put device attribute @wakeup_last_time_ms and its show() together
driver core: class: Correct WARN() message in APIs class_(for_each|find)_device()

Documentation/driver-api/auxiliary_bus.rst | 1 -
arch/alpha/kernel/pci-sysfs.c | 6 +-
drivers/base/auxiliary.c | 31 +--------
drivers/base/cacheinfo.c | 15 ++---
drivers/base/class.c | 4 +-
drivers/base/core.c | 63 ++++++++----------
drivers/base/firmware_loader/main.c | 7 +-
drivers/base/node.c | 12 ++--
drivers/base/power/sysfs.c | 17 ++---
drivers/base/topology.c | 40 ++++++------
drivers/base/trace.h | 6 +-
drivers/cdx/cdx.c | 2 +-
drivers/cxl/port.c | 2 +-
drivers/gpio/gpio-aspeed-sgpio.c | 2 +-
drivers/gpio/gpio-aspeed.c | 2 +-
drivers/gpio/gpio-ep93xx.c | 2 +-
drivers/gpio/gpio-hlwd.c | 2 +-
drivers/gpio/gpio-mlxbf2.c | 2 +-
drivers/gpio/gpio-omap.c | 2 +-
drivers/gpio/gpio-pca953x.c | 2 +-
drivers/gpio/gpio-pl061.c | 2 +-
drivers/gpio/gpio-tegra.c | 2 +-
drivers/gpio/gpio-tegra186.c | 2 +-
drivers/gpio/gpio-tqmx86.c | 2 +-
drivers/gpio/gpio-visconti.c | 2 +-
drivers/gpio/gpio-xgs-iproc.c | 2 +-
drivers/gpu/drm/amd/amdgpu/amdgpu_psp.c | 2 +-
drivers/gpu/drm/display/drm_dp_aux_bus.c | 2 +-
drivers/infiniband/hw/qib/qib_sysfs.c | 2 +-
drivers/irqchip/irq-gic.c | 2 +-
drivers/irqchip/irq-mvebu-pic.c | 2 +-
drivers/irqchip/irq-versatile-fpga.c | 2 +-
drivers/misc/ocxl/sysfs.c | 2 +-
drivers/mtd/spi-nor/sysfs.c | 2 +-
drivers/nvmem/core.c | 16 ++++-
drivers/pci/p2pdma.c | 2 +-
drivers/pci/pci-sysfs.c | 42 ++++++------
drivers/pci/vpd.c | 2 +-
drivers/perf/arm-ni.c | 1 -
drivers/phy/tegra/xusb.c | 2 +-
drivers/pinctrl/bcm/pinctrl-iproc-gpio.c | 2 +-
drivers/pinctrl/mvebu/pinctrl-armada-37xx.c | 2 +-
drivers/pinctrl/pinctrl-mcp23s08.c | 2 +-
drivers/pinctrl/pinctrl-stmfx.c | 2 +-
drivers/pinctrl/pinctrl-sx150x.c | 2 +-
drivers/pinctrl/renesas/pinctrl-rzg2l.c | 2 +-
drivers/platform/x86/amd/hsmp.c | 2 +-
drivers/platform/x86/intel/pmt/class.c | 2 +-
drivers/platform/x86/intel/sdsi.c | 2 +-
drivers/s390/char/con3215.c | 1 -
drivers/scsi/scsi_sysfs.c | 2 +-
drivers/uio/uio_hv_generic.c | 2 +-
drivers/usb/core/sysfs.c | 2 +-
fs/sysfs/file.c | 30 ++++++---
fs/sysfs/group.c | 5 +-
fs/sysfs/sysfs.h | 2 +-
include/linux/auxiliary_bus.h | 4 --
include/linux/list.h | 8 ---
include/linux/sysfs.h | 99 +++++++++++++++++------------
kernel/cpu.c | 3 -
lib/devres.c | 6 +-
61 files changed, 242 insertions(+), 253 deletions(-)