[PATCH net-next v1 3/7] phy: replace bitwise flag definitions with BIT() macro
From: Oleksij Rempel
Date: Tue Dec 03 2024 - 02:57:07 EST
Convert the PHY flag definitions to use the BIT() macro instead of
hexadecimal values. This improves readability and maintainability.
No functional changes are introduced by this modification.
Signed-off-by: Oleksij Rempel <o.rempel@xxxxxxxxxxxxxx>
---
include/linux/phy.h | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/include/linux/phy.h b/include/linux/phy.h
index 20a0d43ab5d4..a6c47b0675af 100644
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
@@ -86,11 +86,11 @@ extern const int phy_10gbit_features_array[1];
#define PHY_POLL -1
#define PHY_MAC_INTERRUPT -2
-#define PHY_IS_INTERNAL 0x00000001
-#define PHY_RST_AFTER_CLK_EN 0x00000002
-#define PHY_POLL_CABLE_TEST 0x00000004
-#define PHY_ALWAYS_CALL_SUSPEND 0x00000008
-#define MDIO_DEVICE_IS_PHY 0x80000000
+#define PHY_IS_INTERNAL BIT(0)
+#define PHY_RST_AFTER_CLK_EN BIT(1)
+#define PHY_POLL_CABLE_TEST BIT(2)
+#define PHY_ALWAYS_CALL_SUSPEND BIT(3)
+#define MDIO_DEVICE_IS_PHY BIT(31)
/**
* enum phy_interface_t - Interface Mode definitions
--
2.39.5