Re: [PATCH v6 7/8] x86/sev: Add full support for a segmented RMP table

From: Borislav Petkov
Date: Thu Dec 12 2024 - 10:43:28 EST


On Thu, Dec 12, 2024 at 08:46:21AM -0600, Tom Lendacky wrote:
> I find it more readable :)

I know. :)

> But, ok, I'll switch to the if statement, especially since you want the
> probed_size check moved here and that only applies to the contiguous RMP
> table.

Bah, I misread.

contiguous_rmptable_setup has:

if (!probed_rmp_size)
return false;

and the segmented:

segmented_rmptable_setup:


if (!probed_rmp_base)
return false;

Forget what I said - keep those checks in the respective functions. Sorry.

> Just matching the way it's done in the contiguous table probe, but I can
> redo.

Please.

The pattern is:

do thing
check above thing's retval

Thx.

--
Regards/Gruss,
Boris.

https://people.kernel.org/tglx/notes-about-netiquette