Re: [PATCH] PCI: endpoint: Replace magic number "6" by PCI_STD_NUM_BARS

From: Bjorn Helgaas
Date: Thu Dec 12 2024 - 14:00:44 EST


On Thu, Dec 12, 2024 at 05:25:47PM +0100, Rick Wertenbroek wrote:
> Replace the constant "6" by PCI_STD_NUM_BARS, as defined in
> include/uapi/linux/pci_regs.h:
>
> Signed-off-by: Rick Wertenbroek <rick.wertenbroek@xxxxxxxxx>

Applied to pci/endpoint for v6.14, thanks!

> ---
> include/linux/pci-epf.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/include/linux/pci-epf.h b/include/linux/pci-epf.h
> index 18a3aeb62ae4..ee6156bcbbd0 100644
> --- a/include/linux/pci-epf.h
> +++ b/include/linux/pci-epf.h
> @@ -157,7 +157,7 @@ struct pci_epf {
> struct device dev;
> const char *name;
> struct pci_epf_header *header;
> - struct pci_epf_bar bar[6];
> + struct pci_epf_bar bar[PCI_STD_NUM_BARS];
> u8 msi_interrupts;
> u16 msix_interrupts;
> u8 func_no;
> @@ -174,7 +174,7 @@ struct pci_epf {
> /* Below members are to attach secondary EPC to an endpoint function */
> struct pci_epc *sec_epc;
> struct list_head sec_epc_list;
> - struct pci_epf_bar sec_epc_bar[6];
> + struct pci_epf_bar sec_epc_bar[PCI_STD_NUM_BARS];
> u8 sec_epc_func_no;
> struct config_group *group;
> unsigned int is_bound;
> --
> 2.25.1
>