[PATCH 00/10] [v2] x86/cpu: Centralize and standardize CPUID leaf naming
From: Dave Hansen
Date: Fri Dec 13 2024 - 15:50:38 EST
Changes from v1:
* Drop bogus "Check MWAIT feature instead of CPUID level" patch
* Add review tags
--
I noticed that the MWAIT code was rather haphazard in how it deals
with CPUID leaf levels. As a result, there were a ton of unnecessary
checks for ->cpuid_level. It is truly the worst offender because
arch/x86, intel_idle and ACPI that want to poke at it.
Move several of the leaf definitions to one place (cpuid.h). Use
the definitions to get rid of magic numbers. Simplify the code
when the CPUID feature level dependencies can be used. Lastly,
change all the leaf names to be consistent.
This does not get *ALL* the leaves. The topology and cache ones
are left along for now, but they can also be converted over.
arch/x86/events/intel/pt.c | 5 ++--
arch/x86/events/intel/pt.h | 3 --
arch/x86/include/asm/cpuid.h | 7 ++++++
arch/x86/include/asm/fpu/xstate.h | 4 ---
arch/x86/include/asm/mwait.h | 1
arch/x86/kernel/acpi/cstate.c | 5 ++--
arch/x86/kernel/cpu/common.c | 7 +++---
arch/x86/kernel/fpu/xstate.c | 26 ++++++++++--------------
arch/x86/kernel/hpet.c | 6 +----
arch/x86/kernel/process.c | 3 +-
arch/x86/kernel/smpboot.c | 5 +---
arch/x86/kernel/tsc.c | 23 ++++++++++-----------
arch/x86/xen/enlighten_pv.c | 5 ++--
drivers/acpi/acpi_pad.c | 5 +---
drivers/dma/ioat/dca.c | 8 ++++---
drivers/idle/intel_idle.c | 6 +----
drivers/platform/x86/intel/pmc/core.c | 7 +++---
17 files changed, 61 insertions(+), 65 deletions(-)