Re: [PATCH v2 3/6] clk: renesas: rzv2h: Simplify BUS_MSTOP macros and field extraction

From: Geert Uytterhoeven
Date: Fri Dec 27 2024 - 09:33:43 EST


Hi Prabhakar,

On Mon, Dec 23, 2024 at 6:37 PM Prabhakar <prabhakar.csengg@xxxxxxxxx> wrote:
> From: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx>
>
> Replace manual bit manipulation in `BUS_MSTOP` with `FIELD_PREP_CONST` and
> `FIELD_GET` macros for better clarity and maintainability. Introduce
> explicit masks (`BUS_MSTOP_IDX_MASK`, `BUS_MSTOP_BITS_MASK`) to improve
> readability.
>
> Signed-off-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx>

Thanks for your patch!

> --- a/drivers/clk/renesas/rzv2h-cpg.c
> +++ b/drivers/clk/renesas/rzv2h-cpg.c
> @@ -582,8 +582,8 @@ static struct rzv2h_mstop
> if (!mstop)
> return NULL;
>
> - mstop->idx = (mstop_data >> 16) & 0xffff;
> - mstop->mask = mstop_data & 0xffff;
> + mstop->idx = FIELD_GET(BUS_MSTOP_IDX_MASK, (mstop_data));
> + mstop->mask = FIELD_GET(BUS_MSTOP_BITS_MASK, (mstop_data));

Nit: no need for the parentheses around mstop_data.

Reviewed-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds