Re: [PATCH v3 7/8] i2c: riic: Use predefined macro and simplify clock tick calculation

From: Andy Shevchenko
Date: Sat Dec 28 2024 - 18:38:05 EST


Fri, Dec 27, 2024 at 11:51:53AM +0000, Prabhakar kirjoitti:
> From: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx>
>
> Replace the hardcoded `1000000000` with the predefined `NANO` macro for
> clarity. Simplify the code by introducing a `ns_per_tick` variable to
> store `NANO / rate`, reducing redundancy and improving readability.

...

> - brl -= t->scl_fall_ns / (1000000000 / rate);
> - brh -= t->scl_rise_ns / (1000000000 / rate);
> + ns_per_tick = NANO / rate;

So, why NANO and not NSEC_PER_SEC?

> + brl -= t->scl_fall_ns / ns_per_tick;
> + brh -= t->scl_rise_ns / ns_per_tick;

--
With Best Regards,
Andy Shevchenko