[PATCH v1 0/2] Cleanup for memfd_create()

From: Isaac J. Manjarres
Date: Thu Jan 02 2025 - 18:07:10 EST


memfd_create() handles all of its logic in a single function. Some of
the logic in the function is also somewhat contrived (i.e. copying the
memfd name from userpace).

This series aims to cleanup memfd_create() by splitting out the logic
into helper functions, and simplifying the memfd name copying to make
the code easier to follow.

This has no intended functional changes.

Isaac J. Manjarres (2):
mm/memfd: Refactor and cleanup the logic in memfd_create()
mm/memfd: Use strncpy_from_user() to read memfd name

mm/memfd.c | 101 +++++++++++++++++++++++++++++++----------------------
1 file changed, 59 insertions(+), 42 deletions(-)

--
2.47.1.613.gc27f4b7a9f-goog