[PATCH v2 0/2] Cleanup for memfd_create()
From: Isaac J. Manjarres
Date: Tue Jan 07 2025 - 13:49:16 EST
memfd_create() handles all of its logic in a single function. Some of
the logic in the function is also somewhat contrived (i.e. copying the
memfd name from userpace).
This series aims to cleanup memfd_create() by splitting out the logic
into helper functions, and simplifying the memfd name copying to make
the code easier to follow.
This has no intended functional changes.
Changes from v1 ==> v2:
- Rebased on top of the mm-unstable branch instead of Linus' master
branch. Base commit on mm-unstable: ca95745c20ad ("mm/memmap: prevent
double scanning of memmap by kmemleak").
Links:
v1: https://lore.kernel.org/all/20250102230658.1112261-1-isaacmanjarres@xxxxxxxxxx/#t
Isaac J. Manjarres (2):
mm/memfd: Refactor and cleanup the logic in memfd_create()
mm/memfd: Use strncpy_from_user() to read memfd name
mm/memfd.c | 101 +++++++++++++++++++++++++++++++----------------------
1 file changed, 59 insertions(+), 42 deletions(-)
--
2.47.1.613.gc27f4b7a9f-goog