Re: [PATCH] KVM: arm64: vgic: Update some comments to improve the code readability

From: Marc Zyngier
Date: Wed Jan 08 2025 - 05:58:45 EST


[Fixing Suzuki's address]
On Wed, 08 Jan 2025 10:39:19 +0000,
Zhiyuan Dai <daizhiyuan@xxxxxxxxxxxxxx> wrote:
>
> This patch updates the comments in the vgic_v3_queue_sgi function
> to improve the readability of the code.
>
> Signed-off-by: Zhiyuan Dai <daizhiyuan@xxxxxxxxxxxxxx>
> ---
> arch/arm64/kvm/vgic/vgic-mmio-v3.c | 7 ++++++-
> 1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/arch/arm64/kvm/vgic/vgic-mmio-v3.c b/arch/arm64/kvm/vgic/vgic-mmio-v3.c
> index ae4c0593d114..f3b328373869 100644
> --- a/arch/arm64/kvm/vgic/vgic-mmio-v3.c
> +++ b/arch/arm64/kvm/vgic/vgic-mmio-v3.c
> @@ -1040,8 +1040,13 @@ static void vgic_v3_queue_sgi(struct kvm_vcpu *vcpu, u32 sgi, bool allow_group1)
> irq->pending_latch = true;
> vgic_queue_irq_unlock(vcpu->kvm, irq, flags);
> } else {
> - /* HW SGI? Ask the GIC to inject it */
> int err;
> +
> + /*
> + * With GICv4.1, vSGI can be directly injected.
> + * So let's pretend that they are HW interrupts,
> + * tied to a host IRQ.
> + */
> err = irq_set_irqchip_state(irq->host_irq,
> IRQCHIP_STATE_PENDING,
> true);

Do you really see this as an improvement? I don't think we need to
paraphrase the code, which is pretty obvious. If anything, I'd happily
remove the *existing* comment.

M.

--
Without deviation from the norm, progress is not possible.