Re: [PATCH v11 6/8] mm: rust: add VmAreaNew for f_ops->mmap()
From: Andreas Hindborg
Date: Thu Jan 09 2025 - 03:24:00 EST
"Alice Ryhl" <aliceryhl@xxxxxxxxxx> writes:
> On Tue, Dec 17, 2024 at 10:31 AM Andreas Hindborg <a.hindborg@xxxxxxxxxx> wrote:
>>
>> "Alice Ryhl" <aliceryhl@xxxxxxxxxx> writes:
>>
>> > This type will be used when setting up a new vma in an f_ops->mmap()
>> > hook. Using a separate type from VmAreaRef allows us to have a separate
>> > set of operations that you are only able to use during the mmap() hook.
>> > For example, the VM_MIXEDMAP flag must not be changed after the initial
>> > setup that happens during the f_ops->mmap() hook.
>> >
>> > To avoid setting invalid flag values, the methods for clearing
>> > VM_MAYWRITE and similar involve a check of VM_WRITE, and return an error
>> > if VM_WRITE is set. Trying to use `try_clear_maywrite` without checking
>> > the return value results in a compilation error because the `Result`
>> > type is marked #[must_use].
>> >
>> > For now, there's only a method for VM_MIXEDMAP and not VM_PFNMAP. When
>> > we add a VM_PFNMAP method, we will need some way to prevent you from
>> > setting both VM_MIXEDMAP and VM_PFNMAP on the same vma.
>> >
>> > Acked-by: Lorenzo Stoakes <lorenzo.stoakes@xxxxxxxxxx> (for mm bits)
>> > Reviewed-by: Jann Horn <jannh@xxxxxxxxxx>
>> > Signed-off-by: Alice Ryhl <aliceryhl@xxxxxxxxxx>
>> > ---
>> > rust/kernel/mm/virt.rs | 181 ++++++++++++++++++++++++++++++++++++++++++++++++-
>> > 1 file changed, 180 insertions(+), 1 deletion(-)
>> >
>> > diff --git a/rust/kernel/mm/virt.rs b/rust/kernel/mm/virt.rs
>> > index 3a23854e14f4..6d9ba56d4f95 100644
>> > --- a/rust/kernel/mm/virt.rs
>> > +++ b/rust/kernel/mm/virt.rs
>>
>> [cut]
>>
>> > + /// Returns whether `VM_READ` is set.
>> > + ///
>> > + /// This flag indicates whether userspace is mapping this vma as readable.
>> > + #[inline]
>> > + pub fn get_read(&self) -> bool {
>> > + (self.flags() & flags::READ) != 0
>> > + }
>>
>> As an afterthought, should we name these getters according to RFC344 [1]
>> (remove get_ prefix)?
>
> Well, perhaps is_readable?
Why not just `readable() -> bool`? That would match the guidelines.
Best regards,
Andreas Hindborg