Re: [PATCH v1 08/29] cxl/region: Split region registration into an initialization and adding part

From: Robert Richter
Date: Thu Jan 09 2025 - 05:30:45 EST


Ming,

On 09.01.25 09:08:32, Li Ming wrote:
> On 1/7/2025 10:09 PM, Robert Richter wrote:

> > +int cxl_endpoint_register(struct cxl_endpoint_decoder *cxled)
> > +{
> > + int rc;
> > +
> > + rc = cxl_endpoint_initialize(cxled);
> > + if (rc)
> > + return rc;
> > +
> > + return cxl_endpoint_add(cxled);
> > +}
> > +EXPORT_SYMBOL_NS_GPL(cxl_endpoint_register, "CXL");
>
> Hi Robert,

> cxl_endpoint_initialize(), cxl_endpoint_add(),
> cxl_endpoint_register() feels like some functions related to an
> endpoint, but I think they are for an endpoint decoder enabling,
> maybe rename them to
> cxl_endpoint_decoder_initialize()/add()/register()?

Yes, this handles the endpoint decoder. I noticed that too but kept
the short naming. Will rename it. This aligns then with other existing
cxl_endpoint_decoder_*() functions.

Thanks for review,

-Robert