[PATCH v4 14/14] of: Improve __of_add_property_sysfs() readability
From: Zijun Hu
Date: Thu Jan 09 2025 - 08:32:05 EST
From: Zijun Hu <quic_zijuhu@xxxxxxxxxxx>
__of_add_property_sysfs() hard codes string "security-" length as 9, but
that is not obvious for readers.
Improve its readability by using strlen().
Signed-off-by: Zijun Hu <quic_zijuhu@xxxxxxxxxxx>
---
drivers/of/kobj.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/of/kobj.c b/drivers/of/kobj.c
index aa887166f0d21030d620d43c864ca76cde1c6d05..44bfe50c6ea6503e3940578de1dfc7fe0583dfb3 100644
--- a/drivers/of/kobj.c
+++ b/drivers/of/kobj.c
@@ -62,10 +62,11 @@ static const char *safe_name(const struct kobject *kobj, const char *orig_name)
int __of_add_property_sysfs(struct device_node *np, struct property *pp)
{
+ const char *security_prefix = "security-";
int rc;
/* Important: Don't leak passwords */
- bool secure = strncmp(pp->name, "security-", 9) == 0;
+ bool secure = strncmp(pp->name, security_prefix, strlen(security_prefix)) == 0;
if (!IS_ENABLED(CONFIG_SYSFS))
return 0;
--
2.34.1