Re: [PATCH] drm/msm: Avoid rounding up to one jiffy

From: Akhil P Oommen
Date: Mon Jan 13 2025 - 05:34:20 EST


On 1/10/2025 4:37 AM, Rob Clark wrote:
> From: Rob Clark <robdclark@xxxxxxxxxxxx>
>
> If userspace is trying to achieve a timeout of zero, let 'em have it.
> Only round up if the timeout is greater than zero.
>
> Fixes: 4969bccd5f4e ("drm/msm: Avoid rounding down to zero jiffies")
> Signed-off-by: Rob Clark <robdclark@xxxxxxxxxxxx>
> ---
> drivers/gpu/drm/msm/msm_drv.h | 10 ++++------
> 1 file changed, 4 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/gpu/drm/msm/msm_drv.h b/drivers/gpu/drm/msm/msm_drv.h
> index fee31680a6d5..451d258b9827 100644
> --- a/drivers/gpu/drm/msm/msm_drv.h
> +++ b/drivers/gpu/drm/msm/msm_drv.h
> @@ -537,16 +537,14 @@ static inline int align_pitch(int width, int bpp)
> static inline unsigned long timeout_to_jiffies(const ktime_t *timeout)
> {
> ktime_t now = ktime_get();
> - s64 remaining_jiffies;
>
> - if (ktime_compare(*timeout, now) < 0) {
> - remaining_jiffies = 0;
> + if (ktime_compare(*timeout, now) <= 0) {
> + return 0;
> } else {

For readability, we can now remove 'else' block and de-nest rest of the
code.

-Akhil

> ktime_t rem = ktime_sub(*timeout, now);
> - remaining_jiffies = ktime_divns(rem, NSEC_PER_SEC / HZ);
> + s64 remaining_jiffies = ktime_divns(rem, NSEC_PER_SEC / HZ);
> + return clamp(remaining_jiffies, 1LL, (s64)INT_MAX);
> }
> -
> - return clamp(remaining_jiffies, 1LL, (s64)INT_MAX);
> }
>
> /* Driver helpers */