Re: [PATCH v1 15/29] cxl/region: Use an endpoint's SPA range to find a region
From: Jonathan Cameron
Date: Tue Jan 14 2025 - 05:59:45 EST
On Tue, 7 Jan 2025 15:10:01 +0100
Robert Richter <rrichter@xxxxxxx> wrote:
> To find the correct region and root port of an endpoint of a system
> needing address translation, the endpoint's HPA range must be
> translated to each of the parent port address ranges up to the root
> decoder.
>
> Calculate the SPA range using the newly introduced callback function
> port->to_hpa() that translates the decoder's HPA range to its parent
> port's HPA range of the next outer memory domain. Introduce the helper
> function cxl_port_calc_hpa() for this to calculate address ranges
> using the low-level port->to_hpa() callbacks. Determine the root port
> SPA range by iterating all the ports up to the root. Store the
> endpoint's SPA range and use it to find the endpoint's region.
>
> Signed-off-by: Robert Richter <rrichter@xxxxxxx>
> ---
> drivers/cxl/core/region.c | 85 ++++++++++++++++++++++++++++++++-------
> drivers/cxl/cxl.h | 1 +
> 2 files changed, 71 insertions(+), 15 deletions(-)
>
> diff --git a/drivers/cxl/core/region.c b/drivers/cxl/core/region.c
> index 09a68e266a79..007a2016760d 100644
> --- a/drivers/cxl/core/region.c
> +++ b/drivers/cxl/core/region.c
> @@ -824,6 +824,41 @@ static int match_free_decoder(struct device *dev, void *data)
> return 1;
> }
>
> +static int cxl_port_calc_hpa(struct cxl_port *port, struct cxl_decoder *cxld,
> + struct range *hpa_range)
> +{
> + struct range hpa = *hpa_range;
> + u64 len = range_len(&hpa);
> +
> + if (!port->to_hpa)
> + return 0;
> +
> + /* Translate HPA to the next upper domain. */
> + hpa.start = port->to_hpa(cxld, hpa.start);
> + hpa.end = port->to_hpa(cxld, hpa.end);
> +
> + if (!hpa.start || !hpa.end ||
On general basis, why can't hpa.start be 0?
It is an unusual physical memory map, but technically possible on some
architectures.
> + hpa.start == ULLONG_MAX || hpa.end == ULLONG_MAX) {
> + dev_warn(&port->dev,
> + "CXL address translation: HPA range invalid: %#llx-%#llx:%#llx-%#llx(%s)\n",
> + hpa.start, hpa.end, hpa_range->start,
> + hpa_range->end, dev_name(&cxld->dev));
> + return -ENXIO;
> + }
> +
> + if (range_len(&hpa) != len * cxld->interleave_ways) {
> + dev_warn(&port->dev,
> + "CXL address translation: HPA range not contiguous: %#llx-%#llx:%#llx-%#llx(%s)\n",
> + hpa.start, hpa.end, hpa_range->start,
> + hpa_range->end, dev_name(&cxld->dev));
> + return -ENXIO;
> + }
> +
> + *hpa_range = hpa;
> +
> + return 0;
> +}
> +
> static int match_auto_decoder(struct device *dev, void *data)
> {
> struct cxl_region_params *p = data;
> @@ -3214,26 +3249,47 @@ cxl_port_find_switch_decoder(struct cxl_port *port, struct range *hpa)
> static int cxl_endpoint_initialize(struct cxl_endpoint_decoder *cxled)
> {
> struct cxl_memdev *cxlmd = cxled_to_memdev(cxled);
> - struct cxl_port *iter = cxled_to_port(cxled);
> - struct range *hpa = &cxled->cxld.hpa_range;
> + struct cxl_port *parent, *iter = cxled_to_port(cxled);
I'd prefer that spit into two lines. Mixing cases that allocate and ones
that don't isn't great for readability. Would also reduce the diff a little
which is always nice!
> + struct range hpa = cxled->cxld.hpa_range;
> struct cxl_decoder *cxld = &cxled->cxld;
>
...