Re: [PATCH 5/6] media: platform: Use str_enable_disable-like helpers

From: Krzysztof Kozlowski
Date: Tue Jan 14 2025 - 16:06:30 EST


On 14/01/2025 21:42, Laurent Pinchart wrote:
> Hi Krzysztof,
>
> Thank you for the patch.
>
> On Tue, Jan 14, 2025 at 08:46:21PM +0100, Krzysztof Kozlowski wrote:
>> Replace ternary (condition ? "enable" : "disable") syntax with helpers
>> from string_choices.h because:
>> 1. Simple function call with one argument is easier to read. Ternary
>> operator has three arguments and with wrapping might lead to quite
>> long code.
>
> It's more difficult to read for me.

That's obviously subjective, but I am surprised that such stuff is
readable for you:

data & XCSI_DLXINFR_SOTERR ? "true" : "false",
video->hq_mode ? "on" : "off", video->jpeg_hq_quality);

or from PCI parts of this set, note that's ternary is split here:

dstat & BT848_DSTATUS_HLOC
? "yes" : "no");

>
>> 2. Is slightly shorter thus also easier to read.
>> 3. It brings uniformity in the text - same string.
>> 4. Allows deduping by the linker, which results in a smaller binary
>> file.
>
> I don't see why the linker can't de-dup string in the current code.
>
> I'm sorry, I just don't see the point in doing this. I'd like to avoid
> those changes in the Linux media subsystem, or at the very least in
> drivers I maintain.

Ack.

Best regards,
Krzysztof