[PATCHv2 00/11] Get rid of PG_reclaim and rename PG_dropbehind

From: Kirill A. Shutemov
Date: Wed Jan 15 2025 - 04:32:39 EST


Use PG_dropbehind instead of PG_reclaim and remove PG_reclaim.

After removing PG_relcaim, PG_readahead is exclusive user of the page
flag bit.

Once PG_reclaim is gone, we can rename PG_dropbehind to PG_reclaim.

Kirill A. Shutemov (11):
mm/migrate: Transfer PG_dropbehind to the new folio
drm/i915/gem: Convert __shmem_writeback() to folios
drm/i915/gem: Use PG_dropbehind instead of PG_reclaim
mm/zswap: Use PG_dropbehind instead of PG_reclaim
mm/truncate: Use folio_set_dropbehind() instead of
deactivate_file_folio()
mm/vmscan: Use PG_dropbehind instead of PG_reclaim
mm/vmscan: Use PG_dropbehind instead of PG_reclaim in
shrink_folio_list()
mm/mglru: Check PG_dropbehind instead of PG_reclaim in
lru_gen_folio_seq()
mm: Remove PG_reclaim
mm/vmscan: Do not demote PG_dropbehind folios
mm: Rename PG_dropbehind to PG_reclaim

drivers/gpu/drm/i915/gem/i915_gem_shmem.c | 18 ++-
fs/fuse/dev.c | 2 +-
fs/proc/page.c | 2 +-
include/linux/mm_inline.h | 18 +--
include/linux/page-flags.h | 23 ++--
include/linux/pagemap.h | 2 +-
include/trace/events/mmflags.h | 4 +-
include/uapi/linux/kernel-page-flags.h | 2 +-
mm/filemap.c | 46 +++----
mm/internal.h | 1 -
mm/migrate.c | 14 +-
mm/page-writeback.c | 16 +--
mm/page_io.c | 15 +--
mm/readahead.c | 4 +-
mm/swap.c | 153 +---------------------
mm/truncate.c | 2 +-
mm/vmscan.c | 28 +---
mm/zswap.c | 2 +-
tools/mm/page-types.c | 8 +-
19 files changed, 65 insertions(+), 295 deletions(-)

--
2.45.2