Re: [PATCH] iommu: Use str_enable_disable-like helpers
From: Jason Gunthorpe
Date: Wed Jan 15 2025 - 14:12:51 EST
On Tue, Jan 14, 2025 at 08:26:42PM +0100, Krzysztof Kozlowski wrote:
> Replace ternary (condition ? "enable" : "disable") syntax with helpers
> from string_choices.h because:
> 1. Simple function call with one argument is easier to read. Ternary
> operator has three arguments and with wrapping might lead to quite
> long code.
> 2. Is slightly shorter thus also easier to read.
> 3. It brings uniformity in the text - same string.
> 4. Allows deduping by the linker, which results in a smaller binary
> file.
>
> Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@xxxxxxxxxx>
> ---
> drivers/iommu/arm/arm-smmu-v3/arm-smmu-v3.c | 3 ++-
> drivers/iommu/arm/arm-smmu/arm-smmu.c | 3 ++-
> drivers/iommu/mtk_iommu.c | 9 +++++----
> drivers/iommu/mtk_iommu_v1.c | 3 ++-
> drivers/iommu/rockchip-iommu.c | 3 ++-
> 5 files changed, 13 insertions(+), 8 deletions(-)
Reviewed-by: Jason Gunthorpe <jgg@xxxxxxxxxx>
Jason