[PATCH 22/29] drm/bridge: Rename atomic hooks parameters to drop old prefix
From: Maxime Ripard
Date: Wed Jan 15 2025 - 16:09:55 EST
All the bridge atomic hooks were using the old_bridge_state name for
their drm_bridge_state parameter. However, this state is the current
state being committed for all of them, which ends up being confusing.
Let's rename it to bridge_state for all of them.
Signed-off-by: Maxime Ripard <mripard@xxxxxxxxxx>
---
include/drm/drm_bridge.h | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/include/drm/drm_bridge.h b/include/drm/drm_bridge.h
index 4b84faf14e368310dd20aa964e8178ec80aa6fa7..8e18130be8bb85fc2463917dde9bf1d281934184 100644
--- a/include/drm/drm_bridge.h
+++ b/include/drm/drm_bridge.h
@@ -303,11 +303,11 @@ struct drm_bridge_funcs {
* there is one) when this callback is called.
*
* The @atomic_pre_enable callback is optional.
*/
void (*atomic_pre_enable)(struct drm_bridge *bridge,
- struct drm_bridge_state *old_bridge_state);
+ struct drm_bridge_state *bridge_state);
/**
* @atomic_enable:
*
* This callback should enable the bridge. It is called right after
@@ -323,11 +323,11 @@ struct drm_bridge_funcs {
* chain if there is one.
*
* The @atomic_enable callback is optional.
*/
void (*atomic_enable)(struct drm_bridge *bridge,
- struct drm_bridge_state *old_bridge_state);
+ struct drm_bridge_state *bridge_state);
/**
* @atomic_disable:
*
* This callback should disable the bridge. It is called right before
* the preceding element in the display pipe is disabled. If the
@@ -340,11 +340,11 @@ struct drm_bridge_funcs {
* signals) feeding it is still running when this callback is called.
*
* The @atomic_disable callback is optional.
*/
void (*atomic_disable)(struct drm_bridge *bridge,
- struct drm_bridge_state *old_bridge_state);
+ struct drm_bridge_state *bridge_state);
/**
* @atomic_post_disable:
*
* This callback should disable the bridge. It is called right after the
@@ -359,11 +359,11 @@ struct drm_bridge_funcs {
* called.
*
* The @atomic_post_disable callback is optional.
*/
void (*atomic_post_disable)(struct drm_bridge *bridge,
- struct drm_bridge_state *old_bridge_state);
+ struct drm_bridge_state *bridge_state);
/**
* @atomic_duplicate_state:
*
* Duplicate the current bridge state object (which is guaranteed to be
--
2.47.1