Re: [PATCH] x86/fred: Optimize the FRED entry by prioritizing high-probability event dispatching

From: H. Peter Anvin
Date: Thu Jan 16 2025 - 20:22:03 EST


On 1/16/25 16:37, Ethan Zhao wrote:

hpa suggested to introduce "switch_likely" for this kind of optimization
on a switch statement, which is also easier to read.  I measured it with
a user space focus test, it does improve performance a lot.  But obviously there are still a lot of work to do.

Find a way to instruct compiler to pick the right hot branch meanwhile make folks
reading happy... yup, a lot of work.


It's not that complicated, believe it or not.

/*
* switch(v) biased for speed in the case v == l
*
* Note: gcc is quite sensitive to the exact form of this
* expression.
*/
#define switch_likely(v,l) \
switch((__typeof__(v))__builtin_expect((v),(l)))

-hpa