Re: [PATCH v6 0/6] kernfs: Use RCU to access kernfs_node::{parent|name}.

From: Tejun Heo
Date: Thu Jan 30 2025 - 13:36:46 EST


On Thu, Jan 30, 2025 at 03:02:01PM +0100, Sebastian Andrzej Siewior wrote:
> Hi,
>
> This started as a bug report by Hillf Danton and aims to access
> kernfs_node::{name|parent} with RCU to avoid the lock during
> kernfs_path_from_node().
>
> I've split the individual fixes in separate patches (#1 to #4). I've
> also split the ::parent and ::name RCU conversation into a single patch
> (#5 and #6).
>
> v5…v6 https://lore.kernel.org/all/20250128084226.1499291-1-bigeasy@xxxxxxxxxxxxx/
> - s/rdt_kn_get_name/rdt_kn_name/
> - s/rdt_get_kn_parent_priv/rdt_kn_parent_priv/
> - s/kn_get_priv/kn_priv/
> - The comment, that has been removed in kernfs_put(), is back.
> - Using rcu_access_pointer() in kernfs_activate_one() and kernfs_dir_pos()
> instead of kernfs_parent() where the pointer is not dereferenced but
> just compared.
>
> v4…v5 https://lore.kernel.org/all/20250124174614.866884-1-bigeasy@xxxxxxxxxxxxx/
> - rdtgroup:
> - Add a comment to rdt_get_kn_parent_priv() regarding lifetime of
> parent.
> - Move individual rcu_dereference_check() invocations into
> rdt_kn_parent() with a comment on lifetime.
> - Use rcu_access_pointer() in kernfs_to_rdtgroup() instead
> rcu_dereference_check(, true)
> - s/kernfs_rcu_get_name/kernfs_rcu_name/
> - Move all rcu_dereference_check() within kernfs into kernfs_parent()
> and extend its checks to have all cases in one spot. Document why
> each case makes sense.
> - kernfs_notify_workfn(): Do unlocks in the reverse order of locks.
> - Add kernfs_root_flags() and use it in cgroup's kn_get_priv() to
> check the right KERNFS_ROOT_INVARIANT_PARENT flag.
>
> v3: https://lore.kernel.org/all/20241121175250.EJbI7VMb@xxxxxxxxxxxxx/
> v2: https://lore.kernel.org/all/20241112155713.269214-1-bigeasy@xxxxxxxxxxxxx/
> v1: https://lore.kernel.org/all/20241108222406.n5azgO98@xxxxxxxxxxxxx/

Whole series looks good to me.

Thanks.

--
tejun