Re: [PATCH 00/13] gpiolib: add gpiods_set_array_value_cansleep

From: Bartosz Golaszewski
Date: Sat Feb 01 2025 - 05:36:38 EST


On Fri, 31 Jan 2025 21:24:40 +0100, David Lechner <dlechner@xxxxxxxxxxxx> said:
> This series was inspired by some minor annoyance I have experienced a
> few times in recent reviews.
>
> Calling gpiod_set_array_value_cansleep() can be quite verbose due to
> having so many parameters. In most cases, we already have a struct
> gpio_descs that contains the first 3 parameters so we end up with 3 (or
> often even 6) pointer indirections at each call site. Also, people have
> a tendency to want to hard-code the first argument instead of using
> struct gpio_descs.ndescs, often without checking that ndescs >= the
> hard-coded value.
>
> So I'm proposing that we add a gpiods_set_array_value_cansleep()
> function that is a wrapper around gpiod_set_array_value_cansleep()
> that has struct gpio_descs as the first parameter to make it a bit
> easier to read the code and avoid the hard-coding temptation.
>
> I've just done gpiods_set_array_value_cansleep() for now since there
> were over 10 callers of this one. There aren't as many callers of
> the get and atomic variants, but we can add those too if this seems
> like a useful thing to do.
>
> ---
> David Lechner (13):
> gpiolib: add gpiods_set_array_value_cansleep()
> auxdisplay: seg-led-gpio: use gpiods_set_array_value_cansleep
> bus: ts-nbus: validate ts,data-gpios array size
> bus: ts-nbus: use gpiods_set_array_value_cansleep
> gpio: max3191x: use gpiods_set_array_value_cansleep
> iio: adc: ad7606: use gpiods_set_array_value_cansleep
> iio: amplifiers: hmc425a: use gpiods_set_array_value_cansleep
> iio: resolver: ad2s1210: use gpiods_set_array_value_cansleep
> mmc: pwrseq_simple: use gpiods_set_array_value_cansleep
> mux: gpio: use gpiods_set_array_value_cansleep
> net: mdio: mux-gpio: use gpiods_set_array_value_cansleep
> phy: mapphone-mdm6600: use gpiods_set_array_value_cansleep
> ASoC: adau1701: use gpiods_set_array_value_cansleep
>
> drivers/auxdisplay/seg-led-gpio.c | 3 +--
> drivers/bus/ts-nbus.c | 10 ++++++----
> drivers/gpio/gpio-max3191x.c | 18 +++++++-----------
> drivers/iio/adc/ad7606.c | 3 +--
> drivers/iio/adc/ad7606_spi.c | 3 +--
> drivers/iio/amplifiers/hmc425a.c | 3 +--
> drivers/iio/resolver/ad2s1210.c | 8 ++------
> drivers/mmc/core/pwrseq_simple.c | 3 +--
> drivers/mux/gpio.c | 4 +---
> drivers/net/mdio/mdio-mux-gpio.c | 3 +--
> drivers/phy/motorola/phy-mapphone-mdm6600.c | 4 +---
> include/linux/gpio/consumer.h | 7 +++++++
> sound/soc/codecs/adau1701.c | 4 +---
> 13 files changed, 31 insertions(+), 42 deletions(-)
> ---
> base-commit: df4b2bbff898227db0c14264ac7edd634e79f755
> change-id: 20250131-gpio-set-array-helper-bd4a328370d3
>
> Best regards,
> --
> David Lechner <dlechner@xxxxxxxxxxxx>
>
>

This looks good to me except for one thing: the function prefix. I would
really appreciate it if we could stay within the existing gpiod_ namespace and
not add a new one in the form of gpiods_.

Maybe: gpiod_multiple_set_ or gpiod_collected_set...?

Bartosz