Re: [PATCH 5/6] USB: gadget: Use str_enable_disable-like helpers

From: Andrew Jeffery
Date: Sun Feb 02 2025 - 22:44:28 EST


On Tue, 2025-01-14 at 21:05 +0100, Krzysztof Kozlowski wrote:
> Replace ternary (condition ? "enable" : "disable") syntax with
> helpers
> from string_choices.h because:
> 1. Simple function call with one argument is easier to read.  Ternary
>    operator has three arguments and with wrapping might lead to quite
>    long code.
> 2. Is slightly shorter thus also easier to read.
> 3. It brings uniformity in the text - same string.
> 4. Allows deduping by the linker, which results in a smaller binary
>    file.
>
> Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@xxxxxxxxxx>
> ---
>  drivers/usb/gadget/function/f_ecm.c         |  4 ++--
>  drivers/usb/gadget/function/f_ncm.c         |  3 ++-
>  drivers/usb/gadget/function/u_serial.c      |  3 ++-
>  drivers/usb/gadget/legacy/inode.c           |  3 ++-
>  drivers/usb/gadget/udc/aspeed-vhub/hub.c    |  3 ++-

Reviewed-by: Andrew Jeffery <andrew@xxxxxxxxxxxxxxxxxxxx> #aspeed