Re: [PATCH v2 08/11] KVM: x86: Pass reference pvclock as a param to kvm_setup_guest_pvclock()
From: Sean Christopherson
Date: Tue Feb 04 2025 - 14:23:47 EST
On Tue, Feb 04, 2025, Paul Durrant wrote:
> On 04/02/2025 09:33, Paul Durrant wrote:
> > On 01/02/2025 01:38, Sean Christopherson wrote:
> > > -static void kvm_setup_guest_pvclock(struct kvm_vcpu *v,
> > > +static void kvm_setup_guest_pvclock(struct pvclock_vcpu_time_info
> > > *ref_hv_clock,
> > > + struct kvm_vcpu *vcpu,
> >
> > So, here 'v' becomes 'vcpu'
> >
> > > struct gfn_to_pfn_cache *gpc,
> > > unsigned int offset,
> > > bool force_tsc_unstable)
> > > {
> > > - struct kvm_vcpu_arch *vcpu = &v->arch;
> > > struct pvclock_vcpu_time_info *guest_hv_clock;
> > > struct pvclock_vcpu_time_info hv_clock;
> > > unsigned long flags;
> > > - memcpy(&hv_clock, &vcpu->hv_clock, sizeof(hv_clock));
> > > + memcpy(&hv_clock, ref_hv_clock, sizeof(hv_clock));
> > > read_lock_irqsave(&gpc->lock, flags);
> > > while (!kvm_gpc_check(gpc, offset + sizeof(*guest_hv_clock))) {
...
> > > @@ -3272,18 +3272,18 @@ static int kvm_guest_time_update(struct
> > > kvm_vcpu *v)
> > > vcpu->hv_clock.flags |= PVCLOCK_GUEST_STOPPED;
> > > vcpu->pvclock_set_guest_stopped_request = false;
> > > }
> > > - kvm_setup_guest_pvclock(v, &vcpu->pv_time, 0, false);
> > > + kvm_setup_guest_pvclock(&vcpu->hv_clock, v, &vcpu->pv_time,
> > > 0, false);
> >
> > Yet here an below you still use 'v'. Does this actually compile?
> >
>
> Sorry, my misreading of the patch... this is in caller context so no
> problem. The inconsistent naming was misleading me.
I feel your pain, the use of "vcpu" for kvm_vcpu_arch in kvm_guest_time_update()
kills me. I forget if David's rework of kvm_guest_time_update() fixes that wart.
If it doesn't, I'll suggest that addition. The only reason I haven't posted a
patch was to avoid a bunch of churn for a rename, but if the function is getting
ripped apart anyways...