[PATCH 0/5] A few more CRC32 library cleanups

From: Eric Biggers
Date: Tue Feb 04 2025 - 19:55:39 EST


This series makes the CRC32 library functions have consistent
prototypes, and it makes the Castagnoli CRC32 be consistently called
simply crc32c instead of a mix of crc32c, crc32c_le, and __crc32c_le.

Eric Biggers (5):
lib/crc32: use void pointer for data
lib/crc32: don't bother with pure and const function attributes
lib/crc32: standardize on crc32c() name for Castagnoli CRC32
lib/crc32: rename __crc32c_le_combine() to crc32c_combine()
lib/crc32: remove "_le" from crc32c base and arch functions

arch/arm/lib/crc32-glue.c | 12 ++---
arch/arm64/lib/crc32-glue.c | 10 ++--
arch/loongarch/lib/crc32-loongarch.c | 6 +--
arch/mips/lib/crc32-mips.c | 6 +--
arch/powerpc/lib/crc32-glue.c | 10 ++--
arch/riscv/lib/crc32-riscv.c | 17 +++---
arch/s390/lib/crc32-glue.c | 2 +-
arch/sparc/lib/crc32_glue.c | 10 ++--
arch/x86/lib/crc32-glue.c | 6 +--
crypto/crc32c_generic.c | 8 +--
drivers/crypto/stm32/stm32-crc32.c | 2 +-
drivers/infiniband/sw/siw/siw.h | 4 +-
drivers/md/raid5-cache.c | 31 ++++++-----
drivers/md/raid5-ppl.c | 16 +++---
.../net/ethernet/broadcom/bnx2x/bnx2x_sp.c | 2 +-
drivers/thunderbolt/ctl.c | 2 +-
drivers/thunderbolt/eeprom.c | 2 +-
include/linux/crc32.h | 53 +++++++++----------
include/linux/crc32c.h | 8 ---
include/net/sctp/checksum.h | 7 +--
lib/crc32.c | 21 ++++----
lib/crc_kunit.c | 2 +-
sound/soc/codecs/aw88395/aw88395_device.c | 2 +-
23 files changed, 111 insertions(+), 128 deletions(-)


base-commit: 2014c95afecee3e76ca4a56956a936e23283f05b
--
2.48.1