Re: [PATCH v1 1/1] accel/habanalabs: Switch to use %ptTs
From: Andy Shevchenko
Date: Thu Feb 06 2025 - 14:14:21 EST
On Thu, Feb 06, 2025 at 05:48:55PM +0200, Andy Shevchenko wrote:
> Use %ptTs instead of open-coded variant to print contents of time64_t type
> in human readable form.
...
> dev_err(hdev->dev,
> - "EQ: {CI %u, HB counter %u, last HB time: %s}, PQ: {PI: %u, CI: %u (%u), last HB time: %s}\n",
> + "EQ: {CI %u, HB counter %u, last HB time: %ptTs}, PQ: {PI: %u, CI: %u (%u), last HB time: %ptTs}\n",
> hdev->event_queue.ci,
> heartbeat_debug_info->heartbeat_event_counter,
> - eq_time_str,
> + hdev->heartbeat_debug_info.last_eq_heartbeat_ts,
This has to be a pointer...
> hdev->kernel_queues[cpu_q_id].pi,
> atomic_read(&hdev->kernel_queues[cpu_q_id].ci),
> atomic_read(&hdev->kernel_queues[cpu_q_id].ci) & pq_pi_mask,
> - pq_time_str);
> + hdev->heartbeat_debug_info.last_pq_heartbeat_ts);
...and this.
I will fix these typos in v2.
--
With Best Regards,
Andy Shevchenko