Re: [PATCH RFC 1/3] rust: add useful ops for u64

From: John Hubbard
Date: Wed Feb 19 2025 - 15:22:51 EST


On 2/19/25 4:51 AM, Alexandre Courbot wrote:
Yes, that looks like the optimal way to do this actually. It also
doesn't introduce any overhead as the destructuring was doing both
high_half() and low_half() in sequence, so in some cases it might
even be more efficient.

I'd just like to find a better naming. high() and low() might be enough?
Or are there other suggestions?


Maybe use "32" instead of "half":

.high_32() / .low_32()
.upper_32() / .lower_32()


thanks,
--
John Hubbard