[PATCH 0/4] Thermal: clean-up with kcalloc()

From: Lukasz Luba
Date: Mon Feb 24 2025 - 12:38:00 EST


Hi all,

This is just small clean-up inspired by this patch [1].
It aims to keep the thermal framework up-to-date with the
recommendations in the community [2]. If there are (or will be)
some static checks in this area, we will be OK.

The patches are on top of latest thermal/linux-next branch

Regards,
Lukasz Luba

[1] https://lore.kernel.org/lkml/20250222-thermal_kcalloc-v1-1-9f7a747fbed7@xxxxxxxxxxxxxxxxx/
[2] https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments

Lukasz Luba (4):
thermal: OF: Use kcalloc() instead of kzalloc() with multiplication
thermal: k3_j72xx_bandgap: Use kcalloc() instead of kzalloc()
thermal: int340x: Use kcalloc() instead of kzalloc() with
multiplication
thermal: hisi: Use kcalloc() instead of kzalloc() with multiplication

drivers/thermal/hisi_thermal.c | 4 ++--
drivers/thermal/intel/int340x_thermal/int340x_thermal_zone.c | 4 ++--
drivers/thermal/k3_j72xx_bandgap.c | 4 ++--
drivers/thermal/thermal_of.c | 2 +-
4 files changed, 7 insertions(+), 7 deletions(-)

--
2.48.1