Re: [PATCH] futex: Use a hashmask instead of hashsize.

From: André Almeida
Date: Wed Feb 26 2025 - 21:00:48 EST


Em 26/02/2025 06:10, Sebastian Andrzej Siewior escreveu:
The global hash uses futex_hashsize to save the amount of the hash
buckets that have been allocated during system boot. On each
futex_hash() invocation this number is substracted by one to get the
mask. This can be optimized by saving directly the mask avoiding the
substraction on each futex_hash() invocation.

Rename futex_hashsize to futex_hashmask and save the mask of the
allocated hash map.

Signed-off-by: Sebastian Andrzej Siewior <bigeasy@xxxxxxxxxxxxx>

Reviewed-by: André Almeida <andrealmeid@xxxxxxxxxx>