Re: [RFC PATCH 6/7] dt-bindings: motion: Add adi,tmc5240 bindings
From: Krzysztof Kozlowski
Date: Fri Feb 28 2025 - 02:11:16 EST
On Thu, Feb 27, 2025 at 05:28:22PM +0100, David Jander wrote:
> +$id: http://devicetree.org/schemas/motion/adi,tmc5240.yaml#
> +$schema: http://devicetree.org/meta-schemas/core.yaml#
> +
> +title: Analog Devices TMC5240 Stepper Motor controller
> +
> +maintainers:
> + - David Jander <david@protonic>
> +
> +description: |
Do not need '|' unless you need to preserve formatting.
> + Stepper motor controller with motion engine and SPI interface.
> +
> +properties:
> + compatible:
> + enum:
> + - adi,tmc5240
> +
> + reg:
> + maxItems: 1
> +
> + interrupts:
> + maxItems: 1
> +
> + enable-supply:
> + description: Optional external enable supply to control SLEEPn pin. Can
That's odd. regular pins are not supplies. This must be named after
physical supplies. There is vdd18, vcc, vcp but nothing about enable
supply in datasheet.
> + be shared between several controllers.
Second sentence is both redundant and really not relevant to this
binding. It's not this binding which decides about sharing.
> +
> + clocks:
> + maxItems: 1
> +
> +required:
> + - compatible
> + - reg
> + - interrupts
> + - clocks
> +
> +allOf:
> + - $ref: /schemas/spi/spi-peripheral-props.yaml#
> + - $ref: /schemas/motion/common.yaml#
> +
> +unevaluatedProperties: false
> +
> +examples:
> + - |
> + spi {
> + #address-cells = <1>;
> + #size-cells = <0>;
> +
> + motor@0 {
> + compatible = "adi,tmc5240";
> + reg = <0>;
> + interrupts-extended = <&gpiok 7 0>;
Include header and use standard defines for flags.
> + clocks = <&clock_tmc5240>;
> + enable-supply = <&stpsleepn>;
> + spi-max-frequency = <1000000>;
Where are any other properties from common schema?
Best regards,
Krzysztof