Re: [PATCH v6 20/42] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers
From: James Morse
Date: Fri Feb 28 2025 - 14:56:10 EST
Hi Babu,
On 27/02/2025 20:26, Moger, Babu wrote:
> On 2/7/25 12:18, James Morse wrote:
>> mon_event_config_{read,write}() are called via IPI and access model
>> specific registers to do their work.
>>
>> To support another architecture, this needs abstracting.
>>
>> Rename mon_event_config_{read,write}() to have a "resctrl_arch_"
>> prefix, and move their struct mon_config_info parameter into
>> <linux/resctrl.h>. This allows another architecture to supply an
>> implementation of these.
>>
>> As struct mon_config_info is now exposed globally, give it a 'resctrl_'
>> prefix. MPAM systems need access to the domain to do this work, add
>> the resource and domain to struct resctrl_mon_config_info.
>> diff --git a/include/linux/resctrl.h b/include/linux/resctrl.h
>> index 5c7b9760b63a..59d944e139f8 100644
>> --- a/include/linux/resctrl.h
>> +++ b/include/linux/resctrl.h
>> @@ -270,6 +270,13 @@ struct resctrl_cpu_defaults {
>> u32 rmid;
>> };
>>
>> +struct resctrl_mon_config_info {
>> + struct rdt_resource *r;
>> + struct rdt_mon_domain *d;
>> + u32 evtid;
>> + u32 mon_config;
>> +};
> Isn't this architecture specific definition? Why is this in common
> resctrl.h file.
Because mbm_config_write_domain() and mbm_config_show() need to pass this set of
information via IPI to another CPU to call resctrl_arch_mon_event_config_read() or
resctrl_arch_mon_event_config_write().
The definition can't belong to the arch code - otherwise it would have to be duplicated
across all architecture, and need the same members.
As much of the IPI-ing as possible is in the resctrl filesystem code, so that if we can
reduce them for one architecture, every architecture benefits.
Thanks,
James