Re: [PATCH RFCv2 06/18] uprobes: Add orig argument to uprobe_write and uprobe_write_opcode
From: Jiri Olsa
Date: Fri Feb 28 2025 - 18:13:06 EST
On Fri, Feb 28, 2025 at 11:07:38AM -0800, Andrii Nakryiko wrote:
> On Mon, Feb 24, 2025 at 6:03 AM Jiri Olsa <jolsa@xxxxxxxxxx> wrote:
> >
> > The uprobe_write has special path to restore the original page when
> > we write original instruction back.
> >
> > This happens when uprobe_write detects that we want to write anything
> > else but breakpoint instruction.
> >
> > In following changes we want to use uprobe_write function for multiple
> > updates, so adding new function argument to denote that this is the
> > original instruction update. This way uprobe_write can make appropriate
> > checks and restore the original page when possible.
> >
> > Signed-off-by: Jiri Olsa <jolsa@xxxxxxxxxx>
> > ---
> > arch/arm/probes/uprobes/core.c | 2 +-
> > include/linux/uprobes.h | 5 +++--
> > kernel/events/uprobes.c | 22 ++++++++++------------
> > 3 files changed, 14 insertions(+), 15 deletions(-)
> >
>
> [...]
>
> > diff --git a/kernel/events/uprobes.c b/kernel/events/uprobes.c
> > index ad5879fc2d26..2b542043089e 100644
> > --- a/kernel/events/uprobes.c
> > +++ b/kernel/events/uprobes.c
> > @@ -471,25 +471,23 @@ static int update_ref_ctr(struct uprobe *uprobe, struct mm_struct *mm,
> > * Return 0 (success) or a negative errno.
> > */
> > int uprobe_write_opcode(struct arch_uprobe *auprobe, struct mm_struct *mm,
> > - unsigned long vaddr, uprobe_opcode_t opcode)
> > + unsigned long vaddr, uprobe_opcode_t opcode, bool orig)
> > {
> > - return uprobe_write(auprobe, mm, vaddr, &opcode, UPROBE_SWBP_INSN_SIZE, verify_opcode);
> > + return uprobe_write(auprobe, mm, vaddr, &opcode, UPROBE_SWBP_INSN_SIZE, verify_opcode, orig);
> > }
> >
> > int uprobe_write(struct arch_uprobe *auprobe, struct mm_struct *mm,
> > unsigned long vaddr, uprobe_opcode_t *insn,
> > - int nbytes, uprobe_write_verify_t verify)
> > + int nbytes, uprobe_write_verify_t verify, bool orig)
>
> why not call orig -> is_register and avoid a bunch of code churn?...
> (and while "is_register" is not awesome name, still a bit more clear
> compared to "orig", IMO)
I see the logic in the function the other way around: if you want to try
and load the original page as part of your update, then you pass true to
orig argument
also the is_register makes sense to me in the old code where you have
just 2 states: breakpoint or original instruction ... now when we added
call instruction the is_register would need to cover that as well
jirka
>
> > {
> > struct page *old_page, *new_page;
> > struct vm_area_struct *vma;
> > - int ret, is_register;
> > + int ret;
> > bool orig_page_huge = false;
> > unsigned int gup_flags = FOLL_FORCE;
> >
> > - is_register = is_swbp_insn(insn);
> > -
>
> [...]