[PATCH 2/4] mm/vmalloc: Size should be used instead of real_size in __vmalloc_node_range_noprof
From: Liu Ye
Date: Mon Mar 03 2025 - 04:45:10 EST
According to the logic of the code, this should be size instead of
real_size. Although there is no functional problem at present,
it is recommended to modify it to enhance readability.
Signed-off-by: Liu Ye <liuye@xxxxxxxxxx>
---
mm/vmalloc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/mm/vmalloc.c b/mm/vmalloc.c
index 20d9b9de84b1..e311ee33f9ef 100644
--- a/mm/vmalloc.c
+++ b/mm/vmalloc.c
@@ -3801,7 +3801,7 @@ void *__vmalloc_node_range_noprof(unsigned long size, unsigned long align,
}
again:
- area = __get_vm_area_node(real_size, align, shift, VM_ALLOC |
+ area = __get_vm_area_node(size, align, shift, VM_ALLOC |
VM_UNINITIALIZED | vm_flags, start, end, node,
gfp_mask, caller);
if (!area) {
--
2.25.1