Re: [PATCH 0/4] drm/amd/display: move from kzalloc(size * nr, ...) to kcalloc(nr, size, ...)
From: Rodrigo Siqueira
Date: Tue Mar 04 2025 - 13:29:08 EST
On 02/27, Ethan Carter Edwards wrote:
> We are trying to get rid of all multiplications from allocation
> functions to prevent integer overflows. Here the multiplications are
> probably safe, but using kcalloc() is more appropriate and improves
> readability. It is also safer. This series contains a few patches
> with these fixes.
>
> Part of the Kernel Self Protection Project efforts. Links below have
> more details.
>
> Link: https://github.com/KSPP/linux/issues/162
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Ethan Carter Edwards <ethan@xxxxxxxxxxxxxxxxx>
> ---
> Ethan Carter Edwards (4):
> drm/amd/display: change kzalloc to kcalloc in dcn30_validate_bandwidth()
> drm/amd/display: change kzalloc to kcalloc in dcn31_validate_bandwidth()
> drm/amd/display: change kzalloc to kcalloc in dcn314_validate_bandwidth()
> drm/amd/display: change kzalloc to kcalloc in dml1_validate()
>
> drivers/gpu/drm/amd/display/dc/resource/dcn30/dcn30_resource.c | 3 ++-
> drivers/gpu/drm/amd/display/dc/resource/dcn31/dcn31_resource.c | 3 ++-
> drivers/gpu/drm/amd/display/dc/resource/dcn314/dcn314_resource.c | 3 ++-
> drivers/gpu/drm/amd/display/dc/resource/dcn32/dcn32_resource.c | 3 ++-
> 4 files changed, 8 insertions(+), 4 deletions(-)
> ---
> base-commit: be5c7bbb3a64baf884481a1ba0c2f8fb2f93f7c3
> change-id: 20250227-amd-display-a8342c55a9a0
>
> Best regards,
> --
> Ethan Carter Edwards <ethan@xxxxxxxxxxxxxxxxx>
>
Hi,
This series LGTM,
Reviewed-by: Rodrigo Siqueira <siqueira@xxxxxxxxxx>
To Display folks,
(Cc some other devs)
If possible, try to include this series in this week's promotion tests,
or check the IGT test in the CI just to be safe.
Thanks
--
Rodrigo Siqueira