Re: [PATCH 2/7] mm/mremap: refactor mremap() system call implementation
From: Harry Yoo
Date: Tue Mar 04 2025 - 20:48:28 EST
On Mon, Mar 03, 2025 at 11:08:32AM +0000, Lorenzo Stoakes wrote:
> Place checks into a separate function so the mremap() system call is less
> egregiously long, remove unnecessary mremap_to() offset_in_page() check and
> just check that earlier so we keep all such basic checks together.
>
> Separate out the VMA in-place expansion, hugetlb and expand/move logic into
> separate, readable functions.
>
> De-duplicate code where possible, add comments and ensure that all error
> handling explicitly specifies the error at the point of it occurring rather
> than setting a prefixed error value and implicitly setting (which is bug
> prone).
>
> This lays the groundwork for subsequent patches further simplifying and
> extending the mremap() implementation.
>
> Signed-off-by: Lorenzo Stoakes <lorenzo.stoakes@xxxxxxxxxx>
> ---
Nice refactoring—reviewing it was a nice learning experience.
Looks good to me,
Reviewed-by: Harry Yoo <harry.yoo@xxxxxxxxxx>
--
Cheers,
Harry
> mm/mremap.c | 405 ++++++++++++++++++++++++++++++++--------------------
> 1 file changed, 251 insertions(+), 154 deletions(-)