Re: [PATCH v7 4/5] Add debugfs based error injection support in DWC

From: 'Krzysztof Wilczyński'
Date: Wed Mar 05 2025 - 02:26:45 EST


Hello,

[...]
> > > > > + 29) Generates duplicate TLPs - duplicate_dllp
> > > > > + 30) Generates Nullified TLPs - nullified_tlp
> > > >
> > > > Would the above field called "duplicate_dllp" for duplicate TLPs be
> > > > a potential typo? Perhaps this should be called "duplicate_tlp"?
> > > >
> > >
> > > Looks like a typo. As per Synopsys documentation, there is only 'duplicate TLP'
> > > field.
> > >
> > > Good catch!
> >
> > Updated. Thank you!
> >
>
> Sorry, this was a typo. Krzysztof, we need another change for this typo.

Not a problem. I am glad we caught this early.

[...]
> --- a/drivers/pci/controller/dwc/pcie-designware-debugfs.c
> +++ b/drivers/pci/controller/dwc/pcie-designware-debugfs.c
> @@ -113,7 +113,7 @@ static const struct dwc_pcie_err_inj err_inj_list[] = {
> {"posted_tlp_data", 0x4, 0x4},
> {"non_post_tlp_data", 0x4, 0x5},
> {"cmpl_tlp_data", 0x4, 0x6},
> - {"duplicate_dllp", 0x5, 0x0},
> + {"duplicate_tlp", 0x5, 0x0},
> {"nullified_tlp", 0x5, 0x1},
> };

Oh here too. No worries. I missed this one. :)

> So sorry for the inconvenience! Should I post a patch for this?

No, no need. I will update this directly on the branch.

Thank you!

Krzysztof