Re: [PATCH net] netpoll: guard __netpoll_send_skb() with RCU read lock
From: Andrew Lunn
Date: Wed Mar 05 2025 - 11:09:47 EST
On Wed, Mar 05, 2025 at 01:09:49AM -0800, Breno Leitao wrote:
> Hello Jakub,
>
> On Tue, Mar 04, 2025 at 05:47:32PM -0800, Jakub Kicinski wrote:
> > On Mon, 03 Mar 2025 03:44:12 -0800 Breno Leitao wrote:
> > > + guard(rcu)();
> >
> > Scoped guards if you have to.
> > Preferably just lock/unlock like a normal person..
>
> Sure, I thought that we would be moving to scoped guards all across the
> board, at least that was my reading for a similar patch I sent a while
> ago:
>
> https://lore.kernel.org/all/20250224123016.GA17456@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/
>
> Anyway, in which case should I use scoped guard instead of just being
> like a normal person?
https://www.kernel.org/doc/html/latest/process/maintainer-netdev.html
Section 1.6.5: Using device-managed and cleanup.h constructs
Netdev remains skeptical about promises of all “auto-cleanup” APIs,
including even devm_ helpers, historically. They are not the
preferred style of implementation, merely an acceptable one.
Use of guard() is discouraged within any function longer than 20
lines, scoped_guard() is considered more readable. Using normal
lock/unlock is still (weakly) preferred.
Low level cleanup constructs (such as __free()) can be used when
building APIs and helpers, especially scoped iterators. However,
direct use of __free() within networking core and drivers is
discouraged. Similar guidance applies to declaring variables
mid-function.
So you need to spend time to find out what each subsystems view is on
various APIs.
Andrew