Re: [PATCH v7 08/49] x86/resctrl: Generate default_ctrl instead of sharing it
From: Reinette Chatre
Date: Thu Mar 06 2025 - 23:33:50 EST
Hi James,
On 2/28/25 11:58 AM, James Morse wrote:
> The struct rdt_resource default_ctrl is used by both the architecture
> code for resetting the hardware controls, and sometimes by the
> filesystem code as the default value for the schema, unless the
> bandwidth software controller is in use.
>
> Having the default exposed by the architecture code causes unnecessary
> duplication for each architecture as the default value must be specified,
> but can be derived from other schema properties. Now that the
> maximum bandwidth is explicitly described, resctrl can derive the default
> value from the schema format and the other resource properties.
>
> Signed-off-by: James Morse <james.morse@xxxxxxx>
> Tested-by: Carl Worth <carl@xxxxxxxxxxxxxxxxxxxxxx> # arm64
> Tested-by: Shaopeng Tan <tan.shaopeng@xxxxxxxxxxxxxx>
> Reviewed-by: Shaopeng Tan <tan.shaopeng@xxxxxxxxxxxxxx>
> Reviewed-by: Tony Luck <tony.luck@xxxxxxxxx>
> ---
> Changes since v6:
> * Return MBA_BW_MAX from delay_bw_map() for improved readability.
> * Generate the bitmap directly in rdt_get_cache_alloc_cfg() to make it
> clear shareable_bits is being generated correctly.
>
> Changes since v5:
> * Rewrote commit message.
>
> Changes since v2:
> * This patch is new.
> ---
> arch/x86/kernel/cpu/resctrl/core.c | 19 +++++++++----------
> arch/x86/kernel/cpu/resctrl/ctrlmondata.c | 5 +++--
> arch/x86/kernel/cpu/resctrl/rdtgroup.c | 6 +++---
> include/linux/resctrl.h | 19 +++++++++++++++++--
> 4 files changed, 32 insertions(+), 17 deletions(-)
>
> diff --git a/arch/x86/kernel/cpu/resctrl/core.c b/arch/x86/kernel/cpu/resctrl/core.c
> index 4504a12efc97..5280a2819760 100644
> --- a/arch/x86/kernel/cpu/resctrl/core.c
> +++ b/arch/x86/kernel/cpu/resctrl/core.c
> @@ -143,7 +143,10 @@ static inline void cache_alloc_hsw_probe(void)
> {
> struct rdt_hw_resource *hw_res = &rdt_resources_all[RDT_RESOURCE_L3];
> struct rdt_resource *r = &hw_res->r_resctrl;
> - u64 max_cbm = BIT_ULL_MASK(20) - 1, l3_cbm_0;
> + u64 max_cbm, l3_cbm_0;
> +
> + r->cache.cbm_len = 20;
> + max_cbm = resctrl_get_default_ctrl(r);
>
> if (wrmsrl_safe(MSR_IA32_L3_CBM_BASE, max_cbm))
> return;
It is unclear to me why this architecture code continues to use
resctrl_get_default_ctrl() while you switched away from it in the other
architecture code.
As resctrl_get_default_ctrl() is "intended for callers that don't know
or care what the format is" [1], here it clearly is required to be a
bitmask. Using resctrl_get_default_ctrl() here also seems to contradict
your argument for not using it in cbm_validate(). [1]
Reinette
[1] https://lore.kernel.org/lkml/fcad500b-3d8c-4003-b25c-6f54d2b5fbe6@xxxxxxx/