Re: [PATCH v3 6/7] perf: Rename perf_event_exit_task(.child)
From: Ravi Bangoria
Date: Mon Mar 10 2025 - 07:08:59 EST
Hi Peter,
On 08-Mar-25 1:03 AM, Peter Zijlstra wrote:
> The task passed to perf_event_exit_task() is not a child, it is
> current. Fix this confusing naming, since much of the rest of the code
> also relies on it being current.
>
> Specifically, both exec() and exit() callers use it with current as
> the argument.
...
> -static void perf_event_exit_task_context(struct task_struct *child, bool exit)
> +static void perf_event_exit_task_context(struct task_struct *task, bool exit)
> {
> - struct perf_event_context *child_ctx, *clone_ctx = NULL;
> + struct perf_event_context *ctx, *clone_ctx = NULL;
> struct perf_event *child_event, *next;
>
> - WARN_ON_ONCE(child != current);
> + WARN_ON_ONCE(task != current);
exec() codepath (i.e. copy_process()) passes child pointer, not 'current'.
Thanks,
Ravi