On Mon, Mar 10, 2025 at 11:20:23AM +0000, John Garry wrote:
On 10/03/2025 11:11, Carlos Maiolino wrote:
On Mon, Mar 10, 2025 at 10:54:23AM +0000, John Garry wrote:
On 10/03/2025 10:06, Carlos Maiolino wrote:I just pushed everything to for-next, so you can just rebase it against for-next
Fine, but I think I then need to deal with spilling multiple lines todiff --git a/fs/xfs/xfs_mount.h b/fs/xfs/xfs_mount.hCould you please rename this to something else? All fields within xfs_mount
index fbed172d6770..bc96b8214173 100644
--- a/fs/xfs/xfs_mount.h
+++ b/fs/xfs/xfs_mount.h
@@ -198,6 +198,7 @@ typedef struct xfs_mount {
bool m_fail_unmount;
bool m_finobt_nores; /* no per-AG finobt resv. */
bool m_update_sb; /* sb needs update in mount */
+ xfs_extlen_t awu_max; /* data device max atomic write */
follows the same pattern m_<name>. Perhaps m_awu_max?
accommodate a proper comment.
I was going to send a patch replacing it once I had this merged, but givingWhat branch do you want me to send this against?
Dave's new comments, and the conflicts with zoned devices, you'll need to send a
V5, so, please include this change if nobody else has any objections on keeping
the xfs_mount naming convention.
Notice this includes the iomap patches you sent in this series which Christian
picked up. So if you need to re-work something on the iomap patches, you'll
probably need to take this into account.
Your branch includes the iomap changes, so hard to deal with.
For the iomap change, Dave was suggesting a name change only, so not a
major issue.
If you don't plan to change anything related to the iomap (depending on the path
the discussion on path 5/12 takes), I believe all you need to do is remove the
iomap patches from your branch, sending only the xfs patches.
So if we really want to go with a name change, then I could add a patch
to change the name only and include in the v5.
Review comments are always welcome, but I wish that they did not come so
late...
That's why I didn't bother asking you to change xfs_mount until now, I'd do it
myself if you weren't going to send a V5.
But Dave's comments are more than a mere naming convention, but logic
adjusting due to operator precedence.