On Fri, Mar 7, 2025, at 23:03, Roman Kisel wrote:
+static int __maybe_unused vmbus_set_irq(struct platform_device *pdev)
Instead of the __maybe_unused annotation here
+#ifndef HYPERVISOR_CALLBACK_VECTOR
+ ret = vmbus_set_irq(pdev);
+ if (ret)
+ return ret;
+#endif
+
you can use
if (!__is_defined(HYPERVISOR_CALLBACK_VECTOR))
ret = vmbus_set_irq(pdev);
and make it a little more readable.
Arnd