Re: [PATCH] rust: file: optimize rust symbol generation for FileDescriptorReservation

From: Kunwu Chan
Date: Sun Mar 16 2025 - 21:27:37 EST


On 2025/3/14 17:21, Alice Ryhl wrote:
On Fri, Mar 14, 2025 at 3:34 AM Kunwu Chan <kunwu.chan@xxxxxxxxx> wrote:
* I think it is easier to read the symbols if you list each sybmol on
one line like this:

ffff8000805b6ef0 T <kernel::fs::file::FileDescriptorReservation>::fd_install
ffff8000805b6e60 T <kernel::fs::file::FileDescriptorReservation>::get_unused_fd_flags
ffff8000805b6f08 T <kernel::fs::file::FileDescriptorReservation as core::ops::drop::Drop>::drop
If in one line, checkpatch.pl will report a warning:

WARNING:Prefer a maximum 75 chars per line (possible unwrapped commit
description?)

If no need to bother with the warning, I'll change it to one line in v2.
You could do this:
... T <kernel::fs::file::FileDescriptorReservation>::fd_install
but if it's still too long I'd just ignore it.

Thanks, I'll change it in v2.


Alice

--
Thanks,
Kunwu.Chan