Re: [PATCH] fs/proc/page: Refactoring to reduce code duplication.

From: Liu Ye
Date: Mon Mar 17 2025 - 05:13:39 EST



在 2025/3/17 16:56, David Hildenbrand 写道:
> On 17.03.25 09:01, Liu Ye wrote:
>> From: Liu Ye <liuye@xxxxxxxxxx>
>>
>> The function kpageflags_read and kpagecgroup_read is quite similar
>> to kpagecount_read. Consider refactoring common code into a helper
>> function to reduce code duplication.
>>
>> Signed-off-by: Liu Ye <liuye@xxxxxxxxxx>
>> ---
>>   fs/proc/page.c | 158 ++++++++++++++++---------------------------------
>>   1 file changed, 50 insertions(+), 108 deletions(-)
>>
>> diff --git a/fs/proc/page.c b/fs/proc/page.c
>> index a55f5acefa97..f413016ebe67 100644
>> --- a/fs/proc/page.c
>> +++ b/fs/proc/page.c
>> @@ -37,19 +37,17 @@ static inline unsigned long get_max_dump_pfn(void)
>>   #endif
>>   }
>>   -/* /proc/kpagecount - an array exposing page mapcounts
>> - *
>> - * Each entry is a u64 representing the corresponding
>> - * physical page mapcount.
>> - */
>> -static ssize_t kpagecount_read(struct file *file, char __user *buf,
>> -                 size_t count, loff_t *ppos)
>> +static ssize_t kpage_read(struct file *file, char __user *buf,
>> +        size_t count, loff_t *ppos,
>> +        u64 (*get_page_info)(struct page *))
>
> Can we just indicate using an enum which operation to perform, so we can avoid having+passing these functions?
>
Like this? Good idea, I'll send a new patch later.

enum kpage_operation {
    KPAGE_FLAGS,
    KPAGE_COUNT,
    KPAGE_CGROUP,
};

static u64 get_page_info(struct page *page, enum kpage_operation op)
{
    switch (op) {
    case KPAGE_FLAGS:
        return stable_page_flags(page);
    case KPAGE_COUNT:
        return page_count(page);
    case KPAGE_CGROUP:
        return page_cgroup_ino(page);
    default:
        return 0;
    }
}

static ssize_t kpageflags_read(struct file *file, char __user *buf,
                               size_t count, loff_t *ppos)
{
    return kpage_read(file, buf, count, ppos, KPAGE_FLAGS);
}

static ssize_t kpagecount_read(struct file *file, char __user *buf,
                               size_t count, loff_t *ppos)
{
    return kpage_read(file, buf, count, ppos, KPAGE_COUNT);
}

static ssize_t kpagecgroup_read(struct file *file, char __user *buf,
                                size_t count, loff_t *ppos)
{
    return kpage_read(file, buf, count, ppos, KPAGE_CGROUP);
}

static ssize_t kpage_read(struct file *file, char __user *buf,
                          size_t count, loff_t *ppos,
                          enum kpage_operation op)
{
        ...
        info = get_page_info(ppage, op);
        ...
}