Re: [PATCH 0/4] ASoC: Intel: avs: move devm_kzalloc(..., size * n, ...) to devm_kcalloc

From: Cezary Rojewski
Date: Mon Mar 17 2025 - 06:32:08 EST


On 2025-03-14 3:38 PM, Ethan Carter Edwards wrote:
Open coded arithmetic in allocator arguments is discouraged. Helper
functions like kcalloc or, in this case, devm_kcalloc are preferred. Not
only for readability purposes but safety purposes.

The changes move `devm_kzalloc(dev, sizeof(var) * n, GFP_KERNEL)` to
the helper function `devm_kcalloc(dev, n, sizeof(var), GFP_KERNEL)`.

Here is a series of four patches within the Intel/avs drivers that make
these changes. They are all compile tested only but should have no
effect on runtime behaviour.
Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
Link: https://github.com/KSPP/linux/issues/162

Signed-off-by: Ethan Carter Edwards <ethan@xxxxxxxxxxxxxxxxx>

Hi Ethan,

Thank you for suggestions. The code looks good, I'd work a bit on the presentation though. For the avs/boards, please keep the title cohesive i.e.: do not drop 'avs' scope:

ASoC: Intel: avs: ssm4567: (the title here)

Do that for all the avs/boards/ patches.

Now, in regard to the title wording - please do reduce the number of special characters when possible. It makes it harder for kernel developers to grep for things. At the same time, being cohesive e.g.: '()' when mentioning functions makes it easier to differentiate functions from types. What I'd suggest is:

ASoC: Intel: avs: ssm4567: Replace devm_kzalloc() with devm_kcalloc()

Plainly states _what_ is being done. Your commit messages plainly answer _why_ do the changes so no update needed there : )

--
Nitpick:

Signing off cover letters is redundant.
Also, I'd suggest to leave 'Link:' tag for the lore.kernel.org links and operate on references instead, e.g.:

Open coded arithmetic in allocator arguments is discouraged [1].
(...)

[1]: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments


Kind regards,
Czarek

---
Ethan Carter Edwards (4):
ASoC: Intel: avs: move devm_kzalloc(..., size * n, ...) to devm_kcalloc
ASoC: Intel: ssm4567: move devm_kzalloc(..., size * n, ...) to devm_kcalloc
ASoC: Intel: max98373: move devm_kzalloc(..., size * n, ...) to devm_kcalloc
ASoC: Intel: max98927: move devm_kzalloc(..., size * n, ...) to devm_kcalloc

sound/soc/intel/avs/boards/max98373.c | 2 +-
sound/soc/intel/avs/boards/max98927.c | 2 +-
sound/soc/intel/avs/boards/ssm4567.c | 2 +-
sound/soc/intel/avs/pcm.c | 2 +-
4 files changed, 4 insertions(+), 4 deletions(-)
---
base-commit: da920b7df701770e006928053672147075587fb2
change-id: 20250314-sound-avs-kcalloc-91cedbc47074

Best regards,