Re: [PATCH 1/2] rust: alloc: replace `Vec::set_len` with `inc_len`

From: Danilo Krummrich
Date: Mon Mar 17 2025 - 07:16:14 EST


On Mon, Mar 17, 2025 at 10:50:15AM +0000, Alice Ryhl wrote:
> On Sun, Mar 16, 2025 at 06:32:00PM -0400, Tamir Duberstein wrote:
> > Rename `set_len` to `inc_len` and simplify its safety contract.
>
> You're missing a Signed-off-by tag.
>
> > rust/kernel/alloc/kvec.rs | 19 +++++++++----------
> > rust/kernel/str.rs | 2 +-
> > rust/kernel/uaccess.rs | 2 +-
> > 3 files changed, 11 insertions(+), 12 deletions(-)
> >
> > diff --git a/rust/kernel/alloc/kvec.rs b/rust/kernel/alloc/kvec.rs
> > index ae9d072741ce..d43a1d609434 100644
> > --- a/rust/kernel/alloc/kvec.rs
> > +++ b/rust/kernel/alloc/kvec.rs
> > @@ -183,17 +183,16 @@ pub fn len(&self) -> usize {
> > self.len
> > }
> >
> > - /// Forcefully sets `self.len` to `new_len`.
> > + /// Increments `self.len` by `additional`.
> > ///
> > /// # Safety
> > ///
> > - /// - `new_len` must be less than or equal to [`Self::capacity`].
> > - /// - If `new_len` is greater than `self.len`, all elements within the interval
> > - /// [`self.len`,`new_len`) must be initialized.
> > + /// - `self.len + additional` must be less than or equal to [`Self::capacity`].
> > + /// - All elements within the interval [`self.len`,`self.len + additional`) must be initialized.
> > #[inline]
> > - pub unsafe fn set_len(&mut self, new_len: usize) {
> > - debug_assert!(new_len <= self.capacity());
> > - self.len = new_len;
> > + pub unsafe fn inc_len(&mut self, additional: usize) {
> > + debug_assert!(self.len() + additional <= self.capacity());
> > + self.len += additional;
>
> I guess we could use an INVARIANT: comment here.

Yeah, I fixed that up in a separate patch. I'm fine with Tamir picking it up or
doing it himself in a new one, etc. But I think this patch should only focus on
the rename.