Re: [PATCH] rust: uaccess: name the correct function

From: Benno Lossin
Date: Mon Mar 17 2025 - 10:33:43 EST


On Mon Mar 17, 2025 at 12:43 PM CET, Tamir Duberstein wrote:
> Correctly refer to `reserve` rather than `try_reserve` in a comment. This
> comment has been incorrect since inception in commit 1b580e7b9ba2 ("rust:
> uaccess: add userspace pointers").
>
> Fixes: 1b580e7b9ba2 ("rust: uaccess: add userspace pointers")
> Signed-off-by: Tamir Duberstein <tamird@xxxxxxxxx>

Reviewed-by: Benno Lossin <benno.lossin@xxxxxxxxx>

---
Cheers,
Benno

> ---
> rust/kernel/uaccess.rs | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/rust/kernel/uaccess.rs b/rust/kernel/uaccess.rs
> index 719b0a48ff55..80a9782b1c6e 100644
> --- a/rust/kernel/uaccess.rs
> +++ b/rust/kernel/uaccess.rs
> @@ -285,8 +285,7 @@ pub fn read_all<A: Allocator>(mut self, buf: &mut Vec<u8, A>, flags: Flags) -> R
> let len = self.length;
> buf.reserve(len, flags)?;
>
> - // The call to `try_reserve` was successful, so the spare capacity is at least `len` bytes
> - // long.
> + // The call to `reserve` was successful, so the spare capacity is at least `len` bytes long.
> self.read_raw(&mut buf.spare_capacity_mut()[..len])?;
>
> // SAFETY: Since the call to `read_raw` was successful, so the next `len` bytes of the
>
> ---
> base-commit: cf25bc61f8aecad9b0c45fe32697e35ea4b13378
> change-id: 20250317-uaccess-typo-reserve-87f20265e6e2
>
> Best regards,