Re: [PATCH v1 3/4] ipv6: sr: factor seg6_hmac_init_algo()'s per-algo code into separate function

From: Paolo Abeni
Date: Tue Mar 18 2025 - 05:07:58 EST




On 3/10/25 5:58 PM, Nicolai Stange wrote:
> In order to prepare for ignoring certain instantiation failures and
> continue with the remaining supported algorithms, factor the per-algo
> initialization code into a separate function:
> - rename seg6_hmac_init_algo() to seg6_hmac_init_algos() and
> - move its per-algo initialization code into a new function,
> seg6_hmac_init_algo().
>
> This is a refactoring only, there is no change in behaviour.
>
> Signed-off-by: Nicolai Stange <nstange@xxxxxxx>
> ---
> net/ipv6/seg6_hmac.c | 88 ++++++++++++++++++++++++--------------------
> 1 file changed, 49 insertions(+), 39 deletions(-)
>
> diff --git a/net/ipv6/seg6_hmac.c b/net/ipv6/seg6_hmac.c
> index 2d7a400e074f..85e90d8d8050 100644
> --- a/net/ipv6/seg6_hmac.c
> +++ b/net/ipv6/seg6_hmac.c
> @@ -380,51 +380,61 @@ static void seg6_hmac_free_algo(struct seg6_hmac_algo *algo)
> }
> }
>
> -static int seg6_hmac_init_algo(void)
> +static int seg6_hmac_init_algo(struct seg6_hmac_algo *algo)
> {
> - struct seg6_hmac_algo *algo;
> - struct crypto_shash *tfm;
> + struct crypto_shash *tfm, **p_tfm;
> struct shash_desc *shash;
> - int i, alg_count, cpu;
> + int cpu, shsize;
> int ret = -ENOMEM;

Please respect the reverse christmas tree order above.

>
> + algo->tfms = alloc_percpu(struct crypto_shash *);
> + if (!algo->tfms)
> + goto error_out;

Could be simply:
return ret;

/P