Re: [PATCH] x86/alternatives: remove false sharing in poke_int3_handler()
From: Peter Zijlstra
Date: Tue Mar 25 2025 - 09:30:27 EST
On Tue, Mar 25, 2025 at 12:26:36PM +0100, Ingo Molnar wrote:
> Yeah, so I do know what #BP is, but what the heck disambiguates the two
> meanings of _bp and why do we have the above jungle of an inconsistent
> namespace? :-)
>
> Picking _int3 would neatly solve all of that.
Sure; the most obvious case where BP would make sense, the trap entry
point, we already use int3 so yeah, make it int3 throughout.