[GIT PULL] auxdisplay for 6.15-1

From: Andy Shevchenko
Date: Tue Mar 25 2025 - 11:35:41 EST


Hi Linus,

I would say it's an average size PR for this small subsystem. Patches were in
the Linux Next for a while (more than a couple of weeks) without reported issues.
It also includes a merge of an immutable tag from GPIO that is used in one of
the cleanups here. Please, pull for v6.15-rc1.

Thanks,

With Best Regards,
Andy Shevchenko

The following changes since commit 2014c95afecee3e76ca4a56956a936e23283f05b:

Linux 6.14-rc1 (2025-02-02 15:39:26 -0800)

are available in the Git repository at:

git://git.kernel.org/pub/scm/linux/kernel/git/andy/linux-auxdisplay.git tags/auxdisplay-v6.15-1

for you to fetch changes up to 67200d70e45982f5120c43b3724f1b6e4a8a01e4:

Merge patch series "auxdisplay: charlcd: Refactor memory allocation" (2025-03-10 18:03:02 +0200)

----------------------------------------------------------------
auxdisplay for v6.15-1

* Refactor a couple of APIs to reduce amount of calls to memory allocator
* Miscellaneous small fixes and improvements

The following is an automated git shortlog grouped by driver:

charlcd:
- Partially revert "Move hwidth and bwidth to struct hd44780_common"

gpiolib:
- add gpiod_multi_set_value_cansleep()

hd44780:
- Rename hd to hdc in hd44780_common_alloc()
- Call charlcd_alloc() from hd44780_common_alloc()
- Make use of hd44780_common_free()
- Introduce hd44780_common_free()
- Fix an API misuse in hd44780.c

lcd2s:
- Allocate memory for custom data in charlcd_alloc()

MAX6959 should select BITREVERSE:
- MAX6959 should select BITREVERSE

panel:
- Make use of hd44780_common_free()
- Fix an API misuse in panel.c

seg-led-gpio:
- use gpiod_multi_set_value_cansleep

----------------------------------------------------------------
Andy Shevchenko (10):
Merge tag 'gpio-set-array-helper-v6.15-rc1' of git://git.kernel.org/pub/scm/linux/kernel/git/brgl/linux into auxdisplay
auxdisplay: panel: Fix an API misuse in panel.c
auxdisplay: charlcd: Partially revert "Move hwidth and bwidth to struct hd44780_common"
auxdisplay: lcd2s: Allocate memory for custom data in charlcd_alloc()
auxdisplay: hd44780: Introduce hd44780_common_free()
auxdisplay: hd44780: Make use of hd44780_common_free()
auxdisplay: panel: Make use of hd44780_common_free()
auxdisplay: hd44780: Call charlcd_alloc() from hd44780_common_alloc()
auxdisplay: hd44780: Rename hd to hdc in hd44780_common_alloc()
Merge patch series "auxdisplay: charlcd: Refactor memory allocation"

David Lechner (2):
gpiolib: add gpiod_multi_set_value_cansleep()
auxdisplay: seg-led-gpio: use gpiod_multi_set_value_cansleep

Geert Uytterhoeven (1):
auxdisplay: MAX6959 should select BITREVERSE

Haoxiang Li (1):
auxdisplay: hd44780: Fix an API misuse in hd44780.c

drivers/auxdisplay/Kconfig | 1 +
drivers/auxdisplay/charlcd.c | 5 +++--
drivers/auxdisplay/charlcd.h | 5 +++--
drivers/auxdisplay/hd44780.c | 19 ++++++-------------
drivers/auxdisplay/hd44780_common.c | 24 ++++++++++++++++--------
drivers/auxdisplay/hd44780_common.h | 4 +++-
drivers/auxdisplay/lcd2s.c | 12 ++++--------
drivers/auxdisplay/panel.c | 17 +++++------------
drivers/auxdisplay/seg-led-gpio.c | 3 +--
include/linux/gpio/consumer.h | 11 +++++++++++
10 files changed, 53 insertions(+), 48 deletions(-)

--
With Best Regards,
Andy Shevchenko